Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] From Premiere to uncompressed AVI intermediate
#1
I finished my Escape from New York project but I find myself stuck near the finish line. I'm new to all this and I need a collective hand (and a hug at this point, why not) because I can't seem to be able to make some steps work.

The story so far:
I worked on Adobe Premiere CS6/After Effects and found out that 1) Encore really sucks at authoring Blu-Rays so it's not an option, 2) exporting/encoding directly from Premiere in H.264 wasn't the wisest choice in the first place (because of its subpar h264 encoder)

So I've been suggested to follow this workflow that I'm sure you're all familiar with: export a lossless intermediate file and then use the native x264.exe to convert this large file into a Blu-Ray compatible H.264 which will then be used with an authoring software (spoRv recommended me EasyBD but I ain't got that far yet!) to create a Blu-Ray.

Since the commonly recommended lagarith is now obsolete and did not seem to integrate at all with my Premiere, I installed UtVideo and with its codecs I could finally export the film from Premiere as a large uncompressed AVI (YUV 4.2.0 BT.709), so obtaining the intermediate avi file.

Where is the problem
From the intermediate file the next step should be to convert it into a Blu-Ray-compatible file thanks to an executable, x264.exe, that can handle the h264 encoding properly. As you all already know (but I'm new to all this) x264 doesn't have a GUI but relies on the use of command prompt to tell it what to do. So, well aware of my ignorance on this type of procedure, I followed given instructions relying but ended nowhere. Where it seems easy for others, I found a wall of errors/can't dos and now I'm totally stuck. Getting help individually from very helpful members residing in different time zones turns this a long-term assistance so I decided to stop being a burden for single individuals and I'm gonna start bothering the whole board with my encoding problems.

Let's start with the script I've been using for pass 1
(my intermediate avi is called EFNY_INTERMEDIATE.avi by the way)

I'm tryin to run this CMD line:

x264.exe --pass 1 --bitrate 27000 --bluray-compat --level 4.1 --preset faster  --tune film --keyint 24 --sar 1:1 --slices 4 --vbv-bufsize 30000 --vbv-maxrate 40000 --b-pyramid none --weightp 0 --colorprim bt709 --transfer bt709 --colormatrix bt709 --merange 24 --stats ".stats" --output NUL "EFNY_INTERMEDIATE.avi

What I get is the following message:
ffms [error]: could not create index
lavf [error]: could not open input file
avs [error]: failed to load avisynth
raw [error]: raw input requires a resolution
x264 [error]: could not open input file 'EFNY_INTERMEDIATE.avi' via any method!


What? How? Why? When?

Additional info: yes, the x264 executable is in the same folder of my intermediate avi. I work on Windows 8.1 64-bit if that matters; I installed  avisynth, ffms and who knows what else, I don't even remember now but I can check it out... so many I installed in the last few days. Don't know what else to add at the moment.
Talk to me like to a little kid, don't worry about it. If anybody has ideas on what can be causing all these difficulties feel free to give me a hand and don't give anything for granted, I might have missed some basic steps. Well, cancel "might".

[FOR ANYONE WHO MIGHT HAVE SIMILAR PROBLEMS IN THE FUTURE: the problem was in the latest version of x264.exe and was solved by using a previous version]
AKA thxita on OriginalTrilogy
I preserve movies as they first appeared in Italy.
Reply
Thanks given by:
#2
I'm at work right now but if no one answers, I'll send you the settings for Megui which has x264 encoder
New, low or non-posting members: Please do not post or PM me asking where to get something or what the current status of a project is. Such requests are ignored. Instead, stick around and become a participating member. Thank you.

Reply
Thanks given by: Evit
#3
Which build of x264 are you using? I had a lot of trouble with the most recent update (2744 64bit), it wasn't recognising my test AVIs and was outputting garbage,  so I rolled back to the previous (2705). Also you will need to drop the " from the filename, x264 will not find your file otherwise. If it still insists on a resolution add --input-res 1920x1080 (not in italics). 
While you are having these startup hiccups I might recommend test encoding a short (approx. 1min) file so that you can be certain that you will get a satifactory encode before you go in for 'the big one'
Reply
Thanks given by: Evit
#4
I downloaded the 64-bit 8-bit-depth of the encoder x264.exe, from here http://www.x264.nl/x264_main.php

I added input-res as you suggested and it started working for 11 frames then x264.exe made an error and crashed.

[Image: avi_EFNY2.png]

lol, right? Dodgy
(By the look of it it was working at 25fps CFR)
AKA thxita on OriginalTrilogy
I preserve movies as they first appeared in Italy.
Reply
Thanks given by:
#5
Here's what i use https://mega.nz/#!mo5nTJAK!P4OtHJUhp7IYk...BjzxkBwKH4
                                                           



Film Addict    
 

New members: Please do not send me a PM about how to acquire a file or project. Participate in forums, just asking for things and not participating will get you nowhere fast.







                                                                   
Reply
Thanks given by: Evit
#6
(2017-01-20, 06:37 PM)DoomBot Wrote: Here's what i use  https://mega.nz/#!mo5nTJAK!P4OtHJUhp7IYk...BjzxkBwKH4

It's bloody working with that release... it seems. 15 minutes ETA for pass-1, is that... possible? That fast?
AKA thxita on OriginalTrilogy
I preserve movies as they first appeared in Italy.
Reply
Thanks given by:
#7
You're having very similar problems to me. In the end I rolled back a build as mentioned above whilst I get to the bottom of it. I think it maybe a problem with the demuxers/media splitters etc. Sorry to hear you're still having problems, don't worry you'll get there in the end!
Reply
Thanks given by: Evit
#8
15min because it's pass 1 but pass 2 will take longer
                                                           



Film Addict    
 

New members: Please do not send me a PM about how to acquire a file or project. Participate in forums, just asking for things and not participating will get you nowhere fast.







                                                                   
Reply
Thanks given by:
#9
For the record, in the end I used this script with the exe that DoomBot passed to me

--pass 1 --bitrate 27000 --bluray-compat --level 4.1 --preset faster  --tune film --keyint 24 --sar 1:1 --slices 4 --vbv-bufsize 30000 --vbv-maxrate 40000 --b-pyramid none --weightp 0 --colorprim bt709 --transfer bt709 --colormatrix bt709 --merange 24 --stats ".stats" --output NUL EFNY_INTERMEDIATE.avi

For pass 2 is this ok?

--pass 2 --bitrate 27000 --bluray-compat --level 4.1 --preset slow --tune film
--keyint 24 --sar 1:1 --slices 4 --vbv-bufsize 30000 --vbv-maxrate 40000 --b-pyramid none
--weightp 0 --colorprim bt709 --transfer bt709 --colormatrix bt709 --merange 24
--stats ".stats" --output EFNY_final.264

am I missing anything? I wait on confirmation before proceeding with pass-2 encode
AKA thxita on OriginalTrilogy
I preserve movies as they first appeared in Italy.
Reply
Thanks given by:
#10
Yes, I forgot to mention I'm using an older version of x264... "if ain't broken, don't fix it!" Big Grin
Sadly my projects are lost due to an HDD crash... Sad
Fundamental Collection | Vimeo channel | My blog
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  Issue Exporting Audio in Premiere Croweyes1121 16 2,129 2020-02-28, 06:13 PM
Last Post: TomArrow
  x264 encoding from Adobe Premiere DoomBot 26 8,606 2019-03-25, 08:26 PM
Last Post: jaminmc
  [Help] Bit depth for standard DTS? [SOLVED] ChainsawAsh 4 2,406 2018-02-20, 11:01 PM
Last Post: ChainsawAsh
  [Help] Problems authoring PCM wave audio in TsMuxer [SOLVED] Evit 8 3,530 2018-01-26, 04:21 PM
Last Post: PDB
  The importance of making "digital intermediate" files spoRv 5 4,415 2017-02-16, 11:37 PM
Last Post: jerryshadoe

Forum Jump:


Users browsing this thread: 1 Guest(s)