Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FLAC muxed with mkvmerge losing sync
#1
Strange thing and it might just be me forgetting to do something but every flac file I mux into a MKV using mkvmerge goes out of sync. It starts fine but slowly drifts as the video progreses.

That's with flac files I have made, flac files others have made and using different audio programs and especially different versions of mkvmerge.

If I convert the flac to PCM, it will merge fine and remains in sync. Convert it back to flac and it's a no go.

Any idea as to what I'm forgetting?
New, low or non-posting members: Please do not post or PM me asking where to get something or what the current status of a project is. Such requests are ignored. Instead, stick around and become a participating member. Thank you.

Reply
Thanks given by:
#2
Very strange, don't think I ever had that problem unless I set the framerate wrong. Just for purposes of covering all corners, have you tried muxing both the PCM and FLAC at the same time and seeing what happens? How big is the drift across the entire movie length? And does the drift happen in every player and even if you fast forward to a specific place?
Reply
Thanks given by:
#3
Yeah, that's strange. I've never experienced the problem, but it sounds as if it's something to do with frame-rate. Try setting the frame-rate of the video manually.
Reply
Thanks given by:
#4
(2019-01-07, 08:57 PM)TomArrow Wrote: Just for purposes of covering all corners, have you tried muxing both the PCM and FLAC at the same time and seeing what happens? How big is the drift across the entire movie length? And does the drift happen in every player and even if you fast forward to a specific place?

Yep tried that. Not sure how big the drift is but enough to be off several seconds at the end. Tired in VLC and various MPC on two PCs with the same results.

(2019-01-07, 08:57 PM)TomArrow Wrote: Very strange, don't think I ever had that problem unless I set the framerate wrong.

(2019-01-07, 09:44 PM)Chewtobacca Wrote: Yeah, that's strange.  I've never experienced the problem, but it sounds as if it's something to do with frame-rate.  Try setting the frame-rate of the video manually.

Let me try the set the frame rate than (23.976 BTW)

Thanks guys
New, low or non-posting members: Please do not post or PM me asking where to get something or what the current status of a project is. Such requests are ignored. Instead, stick around and become a participating member. Thank you.

Reply
Thanks given by:
#5
You might also try ruling out abnormalities in the format of the FLAC file by running it through eac3to.

Code:
eac3to input.flac output.flac

Mux the output, and see if you still experience the problem.
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
Video [Help] Combining two out of sync sources for the best possible output Mediahead 11 1,048 2020-05-22, 03:20 AM
Last Post: Mediahead
  Getting Two Audio Files to Sync Lio 3 751 2019-11-12, 05:33 AM
Last Post: TomArrow

Forum Jump:


Users browsing this thread: 1 Guest(s)